Nanofilm EP³-SE Imaging Ellipsometer (341-G)

Please contact Dr. Amanda Young for training requests and assistance: 979-862-6845, amandayoung@tamu.edu

**Turning on the instrument**

1. Turn on the computer and log into the “User” account

2. Flip key and power button on silver box under instrument (laser and Xe lamp)

3. Start the EP3View software (no login required). The software begins to initialize the instrument and the motors are reset.

4. After initialization, the default windows will be displayed: “Control & Live Image,” the “Script Tree,” and “VI” windows. The Script Tree window contains a function tree with all the available measurement options which are divided into groups depending on measurement. The C&LI window contains the real-time view of the sample plus controls for the instrument that can be changed by clicking on the icon (shutter, wavelength selection, image grab, AoI, polarizer, etc.). The VI window links the EP3 software with the EP4 modeling software.
5. Start the EP4 Model software. This will open a small window in the bottom left corner of the screen with a green button designating that data will be exported to the EP4Model. Clicking this button turns it from green to gray, indicating data will be exported to the old EP3Model program. Opening EP4Model will cause the VI window to close.

6. In the Script Tree window, select File→“change data path.” This will allow you to choose where to save your data files. Find your folder in My Documents or on the desktop so that you are inside the folder you want to save your files to. Click “Select Cur Dir” which should activate the data path. The path should now be visible in the top corner of the Script Tree window.
**Mounting and focusing sample**

1. Check that the objective is chosen under the "Objectives" menu in the C&LI window matches the objective mounted onto the ellipsometer. (We have 10x and 50x.)

2. Place your sample on the stage as far to the back right corner as possible. Make sure that the red laser light from the alignment laser is on the sample (adjust using the XY button in the C&LI window).

   For X: ↑ = away from you; ↓ = towards you  
   For Y: ↑ = right; ↓ = left

   **If your sample has a transparent substrate, it must be placed over the indented part of the stage so the instrument can account for light that passes through the substrate.**


4. Change light wavelength to desired one for measurement (click the text field in the C&LI window containing the laser wavelength and scroll down to desired wavelength)

5. Click on the “Align” button at the bottom right corner of the C&LI window. This will open the Align window. Press "auto align" in this window to level the stage. Close the Align window.

6. To set your desired angle of incidence for measurements, click the number field next to “AOI” in the C&LI window. The AOI window will open. Either type in desired AOI or drag the sliders.

7. Click the “gain” button to auto-adjust the brightness/contrast in the image

8. Adjust the stage’s Z-position up or down using the Z-control (ZS button in bottom right) in order to maximize the real-time ROI (region of interest) signal. You should begin to see an image in the C&LI window.

9. Re-adjust the gain and re-check alignment
10. If no image is seen at this point, try adjusting the angle of the condenser (C). If there is still no image, adjust the polarizer and analyzer (P and A) angles, then double-check that the Z signal is maximized.

11. Adjust the XY position of the stage to center the image on the area you would like to measure by clicking the “XY” button in the C&LI window.

12. Open the Focus/Calibration window by clicking the “focus calib” button (bottom left). Move the red line using the upper slider in the CL&I window (or by clicking on the image when the “+” is selected on the upper right) to a feature in the center of the image window for focusing (typically a dust particle works well). If there are no features near the center of the image, adjust XY so that there is. **Focusing in the center of the image is critical, due to the distortion at the top and bottom of the image from the angle between the laser and objective lens.**

13. In the focus slider window, place the cursor of in the number field between the 2 or 3 numerical places from the right. Use the up/down arrows of the keyboard to slowly move the objective closer/farther away from the sample until the image is in focus (“halos” get smaller/disappear). ( ⊣ = away from sample; ⊤ = closer to sample ) Moving the cursor to the right in the number field moves the objective lens slower. **PLEASE move the objective lens SLOWLY to avoid crashing it into the stage and damaging the lens!**

14. Select the ROI tool on the left hand side of the Control & Live Image window by clicking the “box” icon in the C&LI window and draw a rectangle over the areas you want to measure. If ROIs are already present on image, with the “box” icon selected, mouse over the ROI center until its outline turns from green to gray, then click and drag to move/resize. Additional ROIs can be added by holding the shift button while drawing additional boxes. **It’s important to move your ROIs to a location close to the center focus line in order to obtain the highest quality data. ROIs at the extreme ends of the viewing window are usually yield poor quality data because they are out of focus.**

Capturing ellipsometric contrast images

1. On the top toolbar in the C&LI window, go to “ROI” → “Include ROIs in image grab&scan” to overlay your ROI boxes onto the ellipsometric contrast images that
you will collect. Choose “ROI” → “scalebar” → “XX micron” to add a scalebar to your images.

2. To capture an image, press the camera icon in the bottom left corner of the C&LI window. When the slider above the camera button is at the far LEFT, the image will be “grabbed” and only in focus at the central focal line. If you move the slider all the way to the RIGHT, the image will be captured by rastering from top to bottom across the image with each raster line in focus.

3. To view your image, choose “Windows” → “Map & Image Viewer” from the top toolbar of the Script Tree window. The image that you will see is the “ellipsometric contrast” image and can give qualitative information about your surface. The image can also be viewed in 3D by choosing the 3D Viewer under the Viewing tool. **The 532nm laser will create interference fringes on the ellipsometric contrast image from your sample. These “ridges” are not really present on your film. In order to collect an image without these fringes, select a Xe wavelength (i.e. 552 bright).**

Types of data acquisition

- **Single point**: collects a single data point (delta and psi) at one specified angle and wavelength
- **AOI variation**: collects a data point (delta and psi) at several specified angles using one wavelength; angle range and step can be chosen
- **Lambda variation**: collects a data point (delta and psi) at one specified angle using specified wavelengths; wavelength range and step can be chosen
- **VASE (variable angle spectroscopic ellipsometry)**: collects a data point (delta and psi) at several specified angles using each of several specified wavelengths; angle range/step and wavelength range/step can be chosen
- **Mapping**: collects data points at specified wavelength/angle variations over a particular ROI

### What kind of measurement is appropriate?

<table>
<thead>
<tr>
<th>Applications</th>
<th>Total thickness d[nm] of layer stack under investigation</th>
<th>Kind of measurement</th>
<th>Number of fitparameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>self-assembled monolayer (SAM), micro-contact-printing (µCP), Brewster angle microscopy (BAM), Langmuir-Bludgett film, kinetics in liquid cells</td>
<td>d &lt; 200</td>
<td>Single pair of Δ and Ψ</td>
<td>1...2</td>
</tr>
<tr>
<td>Quality Control of microarray, film on glass substrate, surface plasmon resonance (SPR), thin (20nm &lt; d &lt; 1000nm) anisotropic films, thick (2μm &lt; d &lt; 200μm) isotropic films</td>
<td>d &lt; 20 or d &gt; 2000</td>
<td>AOI-spectrum</td>
<td>2...3</td>
</tr>
<tr>
<td>ITO-film, tiny samples (e.g. cantilever, Laser Diode (LD)), metal substrate with nanoroughness, d/n/k-measurement of a film</td>
<td>20 &lt; d &lt; 2000</td>
<td>Λ-spectrum</td>
<td>3...8</td>
</tr>
<tr>
<td>Organic Light Emitting Device (OLED)</td>
<td>20 &lt; d &lt; 2000</td>
<td>Variable Angle spectroscopic Ellipsometry (VASE)</td>
<td>4</td>
</tr>
</tbody>
</table>

### TIPS FOR CHOOSING MEASUREMENT TYPE:

- If you want to know more than one unknown about your sample (i.e., thickness + refractive index), choose either **AOI variation** or **Lambda variation**

- If your substrate and film are made of **materials in the database**, you can often choose to measure a **single data point** (or set of a few)

- If your film’s **material is NOT in the database**, you should choose **AOI- or Lambda-variation** and take a **large number of data points**
  - If your film is really **thin**, choose **AOI-variation**
  - If your film is **thicker**, choose **lambda variation**

- The number of "**Nulling Zones**" determines the **precision of the delta/psi values**;
  - **One zone** nulling means delta/psi was calculated in **one quadrant** of the Cartesian coordinate system;
  - **Two zone** nulling zones means delta/psi were calculated in **two quadrants** and the same values resulted from both;
  - **Four zone** nulling zones means delta/psi were calculated in **all four quadrants** and the same values resulted from all.
Executing measurement
1. Expand “Measurements” in the Script Tree window by clicking the “+” next to it. Double click “Coarse adjust” in the Script Tree window to get close to the nulling condition (adjusts P and A; not AOI or C).

2. Click the “+” next to your desired measurement type to display the measurement parameters. Adjust parameters according to your sample (i.e., number of nulling zones, AOI range/step, wavelength range/step, etc.) by first clicking on the name of the parameter to highlight it gray, then right clicking on the number. This opens up a new window to type in desired angle/step/wavelength/etc.

3. Execute measurement by double clicking the name of desired measurement type (i.e., “one-zone” under the tree for desired measurement)

4. Monitor the collected data points in the C&LI window by clicking the up/down arrow in the ROI signal window to display “-2” so that all ROI signals will be displayed. Good data points will show parabolas in this window, indicating that a minimum was found. If no data points are parabolas, then consider stopping the measurement, readjusting the alignment/focus calibration/coarse adjustment and re-execute measurement.

Exporting data from the logfile to EP4Model

Method 1: importing directly to EP4 (must have VI connection between EP3 and EP4)
1. In the Script Tree window, choose “Windows” → “Log editor” to open up a spreadsheet of the data you collected

2. In logfile window, rename your logfile by highlighting the number between the parentheses in the title.

3. Select your data in the log file by clicking first in one corner of the area you want to select, then while holding shift click the opposite corner. You will need to select all numerical data starting from the upper left corner (wavelength) and ending with the last Psi value on the right side (just before “plmin(0)”).


5. When you click on each ROI dataset on the left side of the EP4Model window, a spreadsheet of the data points will be displayed in the center of the window. Click the green circle for each data line containing “NaN” so that the circle turns
red. This will exclude these data points from the fit. The program will not be able to fit the data if it contains “NaN” points. (“NaN” points occur if no minimum was found—i.e., no parabola in the PL/ALmin window.)

Method 2: saving data as .txt file and importing manually into EP4

1. In the Script Tree window, choose “Windows” → “Log editor” to open up a spreadsheet of the data you collected.

2. Select your data in the log file by clicking first in one corner of the area you want to select, then while holding shift click the opposite corner. You will need to select all numerical data starting from the upper left corner (wavelength) and ending with the last Psi value on the right side (just before “plmin(0)”).

3. Copy your data to the clipboard by choosing “Tools” → “Selection -> Clipboard”

4. Open Windows notepad and paste your data into it. Save the file as a .txt.

5. In the EP4Model window, choose “Tools” → “Data from Table.” This will open a new window. Click the yellow folder icon in this window and load your saved .txt file.

6. For each ROI, select the wavelength column, angle column, and appropriate delta and psi columns. Press the green check button to import it into the modeling window. Repeat for each ROI, then close window by clicking red X button. Data for each ROI should appear in the EP4Model window under “datasets” near the bottom.
7. When you click on each ROI dataset on the left side of the EP4Model window, a spreadsheet of the data points will be displayed in the center of the window. Click the green circle for each data line containing “NaN” so that the circle turns red. This will exclude these data points from the fit. The program will not be able to fit the data if it contains “NaN” points. (“NaN” points occur if no minimum was found—i.e., no parabola in the PL/ALmin window.)

EP4 modeling

1. Under “Materials” right click and choose
   a. “load material” to load a material from the database.
   b. “create material” to load a dispersion function for an unknown material, then choose “add term” and select a dispersion function from the list. (You need to know approximate film thickness, refractive index, and how light will behave in the unknown material.)
2. Under “Samples” right click and choose “create sample” to add a new sample. You will have to specify the material for each component of your film using the predefined materials or dispersion functions in the “Materials” section. **Don’t forget to add Air for the ambient material.**

3. Bind your datasets to your sample by right clicking on each dataset you imported, selecting “Bind To Sample” and choosing the appropriate sample from the list. If there is not a green check mark next to each dataset, you will also need to right click and choose “Enable/Disable” to activate the dataset.
4. On the far right side of the EP4Model window, check the X axes on the graphs to make sure they reflect the quantity you measured (i.e., AOI vs. wavelength). To change the X axis, right click on the graph to change it.

5. Click “thickness” under “layerstack” in the Sample section. This opens a slider bar where you can adjust the approximation of your film’s thickness and the upper/lower limits of the thickness. To adjust the limits, click on the number and type a new one. As you move the slider back and forth, you should see the graphs on the far right side of the EP4Model window change. Try to adjust the slider such that the model line (solid) overlays your data points.

6. Right click on “Fit for” under your datasets to add fit parameters (i.e., thickness layer #0)

7. In the center part of the EP4Model window, under the “use…” field choose “Delta&Psi”, then press “Start fit”

8. After the fit is complete, results will be displayed in a grid in the middle window with an RMSE curve. Good fit results have a small RMSE and standard deviation. The fit curve will also be displayed on the graphs on the right side of the EP4Model window. The fit line is dashed and has open circles. Ideally, the fit line/points will overlap your data.
Exporting fit data

- **Graphs**: right click on the graph and choose “Save Screenshot” to save an image of both graphs; choose “Save graph data” to save a .txt file of the coordinates for the model line (graph no:0), fit points/line (graph no:1) and the original data points (graph no:2)
- **Fit table**: right click on fit results table. Choose “Export simplified image” and select the desired type of image file.
- **Recipe**: “File” → “Save recipe” saves the materials and sample stacks you’ve loaded/created. You can reload these recipes during subsequent modeling sessions. Saving the recipe does not save the data. You will have to import your data each session.

Shutdown

1. Close the shutter in the C&LI window of EP3View
2. Close all the windows in EP3View. The program will remind you to turn off the lamp/laser.
3. Remove sample from stage
4. Turn off Xe lamp and laser.
Modeling Tips

1. Which dispersion function should I use?
   - Each layer of your material needs a separately defined dispersion function with parameters.
     - Transparent, isotropic material (i.e. glass, polymer) → **Cauchy**
     - Dye (electron movement treated as simple harmonic oscillator) → **Oscillator**
     - Semiconductor: crystalline → **Oscillator, Asymm_Oci**
     - Semiconductor: amorphous (i.e. a-Si, hydrogenated a-Si, a-SiN, TiO₂) → **FourBloom**
     - Lasing material → **Oscillator, Asymm_Osci** \((f_{LO} < 0)\)
     - Metal (Plasmon function in spectroscopic range, oscillator in UV) → **Plasmon**

2. Effective Mixtures (composites):
   - Linear mixing in plane of sample, not vertically → **EM_LinMix**
   - 3D random distribution of guest in host (could be air voids) → **EM_Bruggemann**
   - Mixed molecular dipoles, or spheres w/ volume fraction < 0.3 (charged species in mixture) → **EM_Lorentz**
   - Metal particles in a polymer (guest material has resonance; could be CNT) → **EM_MaxGarn**

3. Why do I get “NaN” as a result for my fit?
   - You must exclude all data points which contain “NaN” in the logfile of collected delta/psi values, or you will get this error
   - You did not “remove” the “default” stack in the “Layers” tab of the model window